Forum begins after the advertisement:

[Part 5] remarks on errors

Home Forums Video Game Tutorial Series Creating a Metroidvania in Unity [Part 5] remarks on errors

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #13197
    Allan Valin

    Hey, I’m here again.

    Changing the Enemy script to use Start() instead of Awake() isn’t mentioned on the blog post (after section 2.c).

    Section 2.d on the video tells to change “this” to “gameObject”, but previous code already had that. Health = maxHealth; is moved from Awake() to Start(), but that isn’t shown on the code (it was just removed), and while it’s shown on the video, it’s very fast and not mentioned.

    The 2D DarkCave Assets pack is said to be in the description of the video, but it isn’t. Though it is on the blog post.

    On Section 3, I noticed that my camera settings weren’t the same as shown in the video, values for Position, Projection, and MSAA were different (I think I followed the tutorial pretty closely, so it was either not mentioned or too fast for me to notice the changes). Also, the Offset value on my script was -20 and the Inspector on the video shows -15.

    I don’t think it was mentioned to remove the previous “Floor” objects from testing.

    About wall placement, video and blog say -1, but a card on the video says 1.

    When adding the fog, I can only see the column if the alpha value is under 20, somehow.
    At the beginning of the video it’s said to make the player a prefab, what about the enemy?

    When adding vegetation, the blog says to use the Multiple mode (and shows a Single image), while the videos doesn’t tell to change that. I tried Multiple and with that you can’t drag and drop the image on the scene, so I assume it was just a copy and paste gone wrong there.

    At 29:22 it’s said to go to Edit > Build Settings, but for me it is File > Build Settings.

    In the blog post, the part about the transition manager doesn’t have a semicolon on “SceneManager.LoadScene(transitionTo)”.

    The public IEnumerator WalkIntoNewScene() has a “<” out of place around line 281 on the Player Controller (blog post). On the blog it shows the line “if (_exitDir.y != 0)” while the video shows “if (_exitDir.y > 0)”.

    The code for PlayerStateList adding “cutscene” isn’t on the blog. Adding “if (pState.cutscene) return;” in Update() and FixedUpdate() isn’t shown as well.

    I think “PlayerController.Instance.pState.cutscene = true;” on the SceneTransition trigger wasn’t mentioned (isn’t on the blog).

    At 34:11 the Exit Time was changed offscreen from 0.25 to 0.5.

    The use of Prefabs for the Scene Transition seems to cause me bugs. Even though I changed the name of the destination, it still uses the value of the prefab instead, e.g. I’d make a prefab of the cave_2 transition, use it on cave_2 and assign it to cave_2, and every time I’d exit cave_2, I’d enter it. At some point I even went to cave_3 when I removed the scene name from the prefab (even though it was still assigned after dragging the prefab to the hierarchy).

    At 35:51 there are multiple steps that aren’t mentioned, and even with the blog description I’m not sure I got it after even watching at 0,25x speed. A script was added, the scene fader was dragged to the prefab… in 10 seconds there are at least 7 steps.
    The part at 36:11 was clearly an edit problem, it shows a previous state of the Scene Fader object, when it didn’t have a script and was still white and not stretched.

    using UnityEngine.UI; isn’t shown on the code for SceneFader.cs on the blog.
    fadeOutUIImage has line break where the serialize field should’ve been removed.
    The code for FadeDirection was skipped and isn’t shown on later codes.
    [SerializeField] private float fadeTime; isn’t declared.
    On UIManager.cs, only sceneFader = GetComponentInChildren<SceneFader>(); is declared, without variable or Start() function shown on the blog.
    The first code block of SceneFader names the class as “UIManager” instead of SceneFader.

    Trying to copy the drag and drop to supposedly update the Prefab I ended up fucking everything up and basically replacing the HP and mana with the scene fader… which made the player prefab lose the reference to mana and I can’t seem to update it correctly.

    When fixing the flashing effect, the variable canFlash isn’t in the code.

    After fixing the flashing effect the player object is shown as lower quality and the camera is zoomed in for whatever reason. It’s like it went to 140p video quality. (restarting the editor fixed it).

    For whatever reason, the heart containerts won’t appear filled up anymore, without me changing anything.

    Starting on part 6 I’ll probably just ask questions if I can’t solve the problems I find.


    Thanks Allan, we’ll get to addressing these ASAP.

    Starting on part 6 I’ll probably just ask questions if I can’t solve the problems I find.

    Sure thing. That might be easier workload wise for you as well. Thanks for all the help!

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.

Go to Login Page →

Advertisement below: